Проблема с QuakeLive

Имеется компьютер с операционной системой Ubuntu 11.04 и браузер Firefox 6.0.2, хочу поиграть в кулив, по при скачивании установочного файла с офф. сайта лиса выдает сообщение: QuakeLive.com Game Launcher не может быть установлено, так как оно не совместимо с Firefox 6.0.2. Подскажите в чем трабла и как ее решить? И нужны ли танцы с бубном для запуска игры под линуксом?